Kuidas WordPress lehekülge ohutult uuendada?

Tere tere veebihuviline! Selles juhendis võtan teemaks WordPress lehekülje uuendamise. Tegemist on tähtsa teemaga, sest sinu lehekülje turvalisus sõltub sellest. Loodan, et selle juhendi abil saad oma veebilehel olevad punased teated ära! Siin juhendis kasutan WP Rollback ja Updraft WordPress Backup pluginaid.

1. Paigalda WP Rollback ja Updraft

Mõlemad mainitud pluginad saad paigalda tavapärasel meetodil. Ära unusta neid aktiveerimast! Kui mõtled, miks neid pluginaid vaja on, siis kohe selgitan. WP Rollback on suurepärane tööriist, kui ükskõik millise sinu WordPress lehel oleva plugina uuendusega tekkisid probleemid. Selle abil saad “aega tagasi” keerates valida varasema versiooni, mis töötas sinu lehega ilusti. Updraft aga võiks olla kasutusel ja ülesse seatud lehekülgedel, kus vajalik koopiate tegemine. Kuigi sinu serveri teenusepakkuja teeb ka ilmselt koopiaid, siis on mõistlik ka ise neid teha. Eriti, kui plaanid oma lehel suuremaid versiooniuuendusi teha.

Pilt 1. Paigalda ja aktiveeri Wp Rollback
Pilt 2. Paigalda ja aktiveeri Updraft

2. Seadista Updraft ja tee varukoopia oma leheküljest

Updrafti puhul on vajalik eelnev seadistamine. Täpsemalt tuleb määrata ära koht, kuhu koopiad sinu leheküljest salvestatakse. Mina kasutan FTP lahendust ja teen koopiad on serverisse, aga valikus on veel palju erinevaid võimalusi koopiate asukohtade salvestamiseks. Kui oled vajalikud väljad täitnud, siis kindlasti testi seadeid. Kui kõik on korras, siis keri lehe lõppu ja salvesta seaded.

PS! Vaata täpsemalt, kuidas Updraft seadistada

Pilt 3. Updraft seadistamine

3. Uuri, mis muudatusi uuendused sisaldavad ja kas see on sobilik sinu lehele

WordPress lehekülg koosneb erinevatest pluginatest ehk juppidest, mis annavad leheküljele funktsionaalsust juurde. See on WordPressi tugevus (lihtne ja mugav) ja nõrkus (palju uuendusi ja ebakõlad üksteise vahel). Seega tuleks enne plugina uuendamist tutvuda, mis järgmises versioonis uut on ning veenduda, et uus versioon on sobilik sinu hetke WordPress versiooniga.

Üldjuhul on pluginate uuendamine ohutu tegevus ning veebilehe haldaja võib seda ise teha. Mõistlik oleks enne uuendamise tegemist natukene oodata, et juhul kui avastati uuel versioonil mõni oluline puudujääk, siis järgmise uuendusega see parandatakse. Ning sa võid kohe teha nt 2.5.1 uuenduse asemel 2.5.3 uuenduse (jättes vahele probleemse uuenduse).

Oluline meeles pidada:

  • Automaatseid pluginate uuendusi ei ole soovitatav sees hoida. Pluginad, mis annavad leheküljele funktsionaalsust juurde, tuleks ettevaatlikult uuendada (nt Woocommerce, MakeCommerce, Elementor jne).
    • välja arvatud pluginatel, mis mõõdavad, loevad või kaitsevad sinu veebilehekülge (nt Yoast SEO, Wordfence, Google Analytics jne).
  • Enne plugina uuendamist loe, mida uuendati. Selleks vajuta “Vaata üksikasju”.
Pilt 4. Pluginad ei sobi omavahel kokku

Pildil 4 on näha, et “Essential Addons for Elementor” ei ole testitud uue Elementor versiooniga 3.2.1. Seega tasuks oodata, kuni kõik pluginad suudetakse vastavusse viia uusima versiooniga.

Pilt 5. Plugina sobivus sinu WordPress versiooniga

Pildil 5 on näha, et pluginad on testitud hetkel kasutusel oleva WordPress versiooniga. Üle tasuks lugeda, mida täpsemalt uuendati/parandati, vajutades “Vaata versiooni x.x.x üksikasju”.

4. Vii läbi uuendused

Kui oled veendunud uuenduste sobivuses, siis vii läbi uuendus. Sul peab eelnevalt olema tehtud leheküljest varukoopia. Kui aga plugina uuendus tekitab lehele probleeme, siis kasuta WP Rollback-i, et võtta kasutusele eelnev versioon pluginast. WP Rollback on suurepärane plugin, sest selle abil saad teha ka uuendusi versioonide kaupa. Oletame, et sul on kasutusel vananenud versioon 1.0 ja uuendust, mida pakutakse on 2.0. WP Rollback abil saad liikuda järkjärgult versioone kaupa (nt 1.1, 1.2, 1.3 …) ja samal ajal veendudes, et kõik töötab.

Pilt 6. WP Rollback võimaldab erinevaid versioone valida

Märkus: Kuna WordPress ja ka pluginad pidevalt uuenevad, siis võib sinu vaade erineda juhendis olevast. Juhendi tegemise hetkel oli WP Rollback 1.7.1 ja Updraft 1.16.56.